Building A Windows Embedded Standard 7 Image For The Aries SBC

BSP User Manual – Part Number 7480740

<table>
<thead>
<tr>
<th>Revision</th>
<th>Date</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>A.00</td>
<td>10/28/2015</td>
<td>Initial release</td>
</tr>
</tbody>
</table>

© Copyright 2015
Diamond Systems Corporation
555 Ellis Street
Mountain View, CA 94043 USA
Tel 1-650-810-2500
Fax 1-650-810-2525
www.diamondsystems.com
## CONTENTS

1. INTRODUCTION ............................................................................................................................................. 3
2. SCOPE ................................................................................................................................................................. 3
3. TARGET HARDWARE REQUIREMENTS .............................................................................................................. 3
4. SYSTEM REQUIREMENTS ................................................................................................................................. 4
   4.1 DEVELOPMENT COMPUTER : .......................................................................................................................... 4
5. FEATURES AND DRIVER DETAILS .................................................................................................................. 4
6. BUILDING AND DEPLOYING A RUN-TIME IMAGE .......................................................................................... 5
   6.1 GENERATING PMQ FILE................................................................................................................................. 5
   6.2 CREATING ANSWER FILE AND IMPORTING PMQ FILE .......................................................................... 7
   6.3 ADDING COMPONENTS TO THE ANSWER FILE.......................................................................................... 9
   6.4 CREATING A USB INSTALLATION MEDIA ................................................................................................. 16
   6.5 EXTRACTING WIM FILE ............................................................................................................................... 22
   6.6 USING THE FINAL IMAGE: .......................................................................................................................... 22
   6.7 INSTALLING DRIVERS AND SOFTWARE FOR ARIES ............................................................................... 23
   6.8 BOOTING TO WINDOWS WELCOME MODE ................................................................................................. 28
7. APPENDIXES ....................................................................................................................................................... 29
   APPENDIX A: STEPS TO MAKE USB/ SATADOM DRIVE BOOTABLE: ............................................................ 29
   APPENDIX B: STEPS TO INSTALL WINDOWS EMBEDDED STANDARD 7 TOOLKIT ON A DEVELOPMENT
   COMPUTER......................................................................................................................................................... 30
   APPENDIX C: STEPS TO TEST HTTP SERVER: ................................................................................................. 30
   APPENDIX D: STEPS TO TEST FTP SERVER: ..................................................................................................... 31
   APPENDIX E: STEPS TO TEST OS PRODUCT KEY LICENSE: ........................................................................ 36
   APPENDIX F: STEPS TO START HYPERTERMINAL .......................................................................................... 36
   APPENDIX G: STEPS TO CREATE WINPE BOOTABLE USB DRIVE: .............................................................. 36
   APPENDIX H: STEPS TO FORMAT SATADOM ................................................................................................. 37
   APPENDIX I: STEPS TO APPLY WES7 IMAGE............................................................................................... 38
1. INTRODUCTION

Windows Embedded Standard 7 is a componentized version of Windows 7 Professional that contains all of the features, functionality, and familiarity of the Windows 7 Professional operating system. Windows Embedded Standard 7 enables you to rapidly develop reliable and full-featured connected devices. Windows Embedded Standard 7 supports standard hardware and software which makes building a run-time image easier.

2. SCOPE

This document details the steps involved in creating, customizing and installing the Windows Embedded Standard 7 for the Aries single board computer.

3. TARGET HARDWARE REQUIREMENTS

Aries SBC with the following specifications:

- Quad core E3845 1.91GHz or dual core E3826 1.46Ghz processor
- 2GB or 4GB soldered DDR3 SDRAM
- 2 Gigabit Ethernet ports
- 1 SATA port socket
- 3 USB 2.0 ports and 1 USB 3.0 port
- 4 RS-232/422/485 serial ports
- 24-bit LVDS LCD display with dual independent displays
- VGA CRT video output
- HDMI
- DisplayPort
- ALC892 HD Audio
- Programmable Watchdog Timer (from data acquisition FPGA)
- Shared expansion socket auto-selects for either PCIe MiniCard or mSATA flashdisk modules
- PCI-104 expansion socket
- PC/104 expansion socket
- Universal Driver 7.0 for data acquisition
4. SYSTEM REQUIREMENTS

The following hardware and software are required to create the WE7 image for the Aries SBC.

4.1 Development Computer:

Hardware
The development computer must meet or exceed the following hardware requirements:

- 1 GHz 32-bit (x86) or 64-bit (amd64) processor
- 1 GB of system memory (32-bit), 2 GB of system memory (64-bit)
- 7 GB free hard drive space for complete installation
- One or more of the following media drives:
  - USB 2.0 port

Software
The development computer needs to have the following software requirements:

- It must be running Windows 7 operating system
- It must have Microsoft .NET Framework 2.0 or higher installed
- Microsoft Windows Embedded Standard 7 Tool kit must have been installed in the Development PC. Please see Appendix B for instructions on installation of the WES7 tool kit on your development PC.

5. FEATURES AND DRIVER DETAILS

The BSP image will have all of the following device drivers installed and pre-configured.

- Display driver
- USB 3.0 driver
- Network Adapter driver
- Windows Embedded IO driver
- Universal Driver 7.0
- HTTP, FTP servers pre-installed
- HyperTerminal
- AriesTestAppsv0.1 file in folder c:
6. BUILDING AND DEPLOYING A RUN-TIME IMAGE

The section will explain the steps to be followed to create the target Windows Embedded Standard 7 image.

6.1 Generating PMQ File

The device component includes support for all the hardware attached to your system, including device drivers for video, networking, and so on. Below is the step-by-step procedure to create a target device component:

- Take a USB thumb drive of capacity 4GB or more, insert it to Development PC and format it. Open ICE (Image Configuration Editor) that comes installed with the Windows Standard 7 Tool Kit. Go to Tools->Create Media->Create IBW Image with Full Distribution Share.

![Image Configuration Editor]

**Figure 1: Image Configuration Editor**

- Select the target folder for the image. Give the thumb drive as the destination, here its k.

![Create IBW Disk]

**Figure 2: Create IBW Disk**

*Note: Use k: and not k:1*
• Insert the thumb drive into the Aries SBC and start the SBC. Windows will start loading. **Note:** If any other media is connected then make the thumb drive boot order the first one in the BIOS settings.

• Wait for the window shown below.

![Launch WinPE Command Prompt](image)

**Figure 3: Launch WinPE Command Prompt**

• Click on Launch WinPE Command Prompt.
• Enter the following commands from the DOS Command Prompt:
  
  ```
  X:\sources> copy tap.exe c:\
  X:\sources> cd c:\
  C:\> tap.exe
  ```

Here c:\ is the thumb drive that has been formatted to use WinPE. Once tap.exe is executed as above, *devices.pmq* file will be generated in C:\ i.e. the thumb drive in this case.

The *devices.pmq* file that is generated has the hardware details of the target Aries SBC.

• Format the SATADOM disk by following the steps in Appendix A.
• Copy the *devices.pmq* file from the thumb drive into the development PC as *Aries.pmq*. 
6.2 Creating Answer File and Importing PMQ File

Start ICE (Image Configuration Editor).

- Go to File menu choose **New Answer File**. (Ctrl N)

![Figure 4: Select New Answer File](image)

- From the **File** menu, choose **Import->Import PMQ**.

![Figure 5: Import PMQ](image)
The **Import PMQ File** dialog box appears. Select the *devices_aries.pmq* file from the directory where you copied it from the thumb drive.

![Figure 6: Select PMQ File](image-url)
6.3 Adding Components to the Answer File

To add packages to the answer file, right-click the package and click **Add to Answer File** (or double-click the component that has to be added to the answer file). There is no limit to the number of packages that can be added to the answer file; however, the size of the image grows as more packages are added. Most of the packages added here come installed with a normal Windows 7 image, but the packages can be added as required.

1. In the **Distribution Share** pane, click **Packages**, and then click **FeaturePack** and add the packages listed below to the answer file.

![Figure 7: Add Packages to Answer File](image1.png)

![Figure 8: List of Added Component to the Answer File](image2.png)
Similarly add the following components to the answer file:

- .NET Framework -> .Net Framework 2.0
- .NET Framework -> .Net Framework 2.0 Client Profile
- Application Support -> COM OLE Application Support
- Application Support -> COM+ Application Support
- Application Support -> Win32 Application Runtimes and Libraries
- Boot Environment -> Windows Boot Environment
- Browsers -> Internet Explorer 8
- Data Access and Storage -> Windows Data Access Components
- Data Integrity -> Shadow Copy Volume Interface
- Devices and Printers -> Device Framework
- Devices and Printers -> Device User Experience
- Devices and Printers -> Driver Frameworks
- Diagnostics -> Common Diagnostic Tools
- Diagnostics -> problem Reports and Solutions
- Embedded Enabling features -> Bootable Windows USB Stack
- Internet Information Services – IIS
- Management -> System Management
- Management -> Windows Update
- Management -> Power Management
- Management -> Windows Application Compatibility
- Management -> Windows Power Shell 2.0
- Networking -> Base
- Networking -> BITS
- Networking -> Domain Services
- Networking -> IRDA and UNIMODEM
- Networking -> Network and Sharing Center
- Networking -> Network Diagnostics
- Networking -> Peer Networking
- Networking -> Quality of Service
- Networking -> Remote Access Service (RAS)
- Networking -> Small Networking Services
- Networking -> Telephony API Client
- Networking -> Telnet Server
- Networking -> Windows Firewall
- Networking -> Wireless Networking
- Remote Connections -> Remote Desktop Connection
- Security -> Active Directory Rights Management
- Security -> Application Security
- Security -> Bitlocker Secure Startup
- Security -> Security Base
- Security -> Trusted Platform Module (TPM) Management
- System Services -> File System
- System Services -> Remote Procedure Call
- System Services -> Windows Installer
- User Interface -> Help
- User Interface -> Windows Shell
- User Interface -> Accessibility
- User Interface -> Mobility Center and SideShow
- User Interface -> Natural Language 6
- User Interface -> Search Indexing
- User Interface -> Text Services Framework
- User Interface -> Windows Search
- Graphics and Multimedia -> Windows Media Player 12

2. In the Distribution Share pane, click Packages, and then click Driver and add Multifunction -> Generic Multifunction Card Driver

3. In the Distribution Share pane, click Packages, and then click LanguagePack and add the package en-US to the answer file by following the above step.

4. In the Answer File pane, click FeaturePack->Embedded Enabling Features->Bootable Windows USB Stack->Kernel PnP_x86. In the right side Window Go to Settings, change the Filter view by to “2 Offline Servicing”. Then Change the following values to 6 and 15000.

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
<th>Path</th>
<th>Pass</th>
</tr>
</thead>
<tbody>
<tr>
<td>BootDriverFlags</td>
<td>6</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PoolBootPartitionTimeout</td>
<td>15000</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The updated values will appear as:

![Updated Values](image.png)

Figure 9: Kernel-PnP_X86

5. In the Answer File pane, click FeaturePack->Security->Application Security->LUA-Settings_x86. Similar to above step, go to Settings and change Filter view by to 2 Offline Servicing. The change the value to True.
6. In the Answer File pane, Click **Product->Operating System->Foundation Core->Windows Embedded Edition->PnpSysprep_x86**. Go to the right side of the IDE to the **Settings Window**, and change **File view by** to **3 Generalize**.

Change the value to true.

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
<th>Path</th>
<th>Pass</th>
</tr>
</thead>
<tbody>
<tr>
<td>EnableLUA</td>
<td>true</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DoNotCleanUpNonPresentDevice</td>
<td>true</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PersistAllDeviceInstalls</td>
<td>true</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
7. In the Answer File pane, Click Product->Operating System->Foundation Core->Windows Embedded Edition, and go to the right window Settings, change File view by to 4 Specialize and provide the ProductKey value.

8. After adding all the components, dependencies have to be resolved because some of the components added above may depend on some components to be successfully installed.

To validate go to Validate->Validate Only (or simply press F5). After the validation is complete, the Message Window will list all the dependencies as shown in the below image:

Figure 11: PnpSysprep_x86

[Image of the Answer File pane showing settings for PnpSysprep_x86]

Figure 12: List of Dependencies

[Image of the Message Window showing dependencies]
Double click on the dependency which is to be resolved.

![Dependency Resolution Example](image1.png)

**Figure 13: Resolving Dependencies**

Check the box “requires all of”. This will add all the required packages to the answer file.

Below is the example of resolving the dependency by checking the “COM OLE Application Support”.

![Toolbox Example](image2.png)

**Figure 14: Check the requirements all of option**

Click the “OK” button:
Similarly resolve all remaining dependencies.

**Note:** You should resolve all the other dependencies using similar method before moving on to the next step.

Now the Answer File is ready for Deployment. So go to **File > Save Answer File As**... (Or simply press Ctrl S), and save it as any name, for example Aries.xml.
6.4 Creating a USB installation media

- Take one 4GB or bigger sized thumb drive called thumb drive1. Connect the thumb drive1 to the development PC. Format it to the Windows NTFS file format. Note the thumb drive’s Drive letter assigned to it such as I:
- Go to Image Configuration Editor again where the Aries.xml answer file is open. If the file is not open then open the answer file.

Go to Tools->Create Media->Create IBW image From Answer File…

The Window to configure the target folder where the image has to be created will appear. Give the thumb drive drive-letter such as I: as below:

**Note:** Please only use “driver letter followed by :” like I: and not I:\

Click on the “OK” button. It will take few minutes to create the image. Once the image creation is successful, the image is ready to be installed on the target board.

Insert the thumb drive1 in the Aries SBC and start the computer. Windows will start loading. Wait until the following Window appears:
Figure 18: Install Windows

**Note:** Don’t connect any other bootable media. If any other bootable media is connected like a hard drive then change the BIOS boot order to boot from **thumb drive1**.

Accept the License terms and click “Next”. The next screen will be to select the language settings. Click on “Next” button the default is **US-English**.

**Note:** If any other language is required, then the language has to be added while adding components from the **Language Pack** as mentioned earlier (See MSDN documentation).
Next step is to configure the target where Windows Embedded Standard 7 will be installed. The window asks “Where do you want to install Windows”. Ensure that the SATADOM is formatted as mentioned in Appendix H before proceeding further.

If a SATADOM is connected to the SBC in its SATA interface, the Windows 7 OS must

- Choose the SATADOM disk as destination for installation:
Select SATADOM disk of 32GB capacity and click next. It will take long time (4-5 hours or more) to complete the installation. There may be several restarts during the installation. After the first restart remove the thumb drive\textsuperscript{1} (which has the Setup) from the Aries SBC.

After removing the thumb drive\textsuperscript{1} copy the AutoUnattend.xml from the thumb drive to some directory. This file will be used later.

\textbf{Note: If the thumb drive\textsuperscript{1} was not removed after first reboot, board may boot from thumb drive\textsuperscript{1}. In that case the following screen will appear:}

![Select Language](image.png)

\textbf{Figure 21: Select Language}

Power down the SBC, remove the thumb drive\textsuperscript{1}, and continue by restarting the SBC.
Wait until the below shown image appears:

![Create Username](image)

**Figure 22: Create Username**

**Don’t configure the User Name details before entering the audit mode.** Press Ctrl+Shift+F3, the SBC will enter to audit mode. The system will restart and boot to the Desktop.

Whenever the system restarts, the below Window may appear on the desktop. Cancel it by clicking on “Cancel” button:

![System Preparation Tool](image)

**Figure 23: System Preparation tool**
Another error message such as the one shown below may appear if there is any problem with sysprep due to the speed limitation of the thumb drive. Click “OK” button and continue with the next step.

![Error message](image)

**Figure 24: Error while querying for pending operations**

Open a command prompt with administrator privilege. Enter the following command.

```cmd
C:\> C:\Windows\System32\sysprep\sysprep.exe /audit /generalize /shutdown
```

Wait for the system to be shutdown properly.
6.5 Extracting WIM File

Note: This step is required only if the .wim file has to be created so that the same image can be used multiple times. Otherwise proceed with the next step.

1. Connect the SATADOM which contains Windows 7 and the SATADOM which contains the WES installed to the Aries SBC.
2. Boot the SBC from the SATADOM.
3. Windows built in ImageX tool can be used to capture the image, if ImageX tool is not present, copy the imageX tool to the C:\Windows\System32 folder.
4. Open the command prompt with Administrator privileges and run the below command:

   C:\Windows\System32> imagex.exe /capture d: c:\Aries.wim 1

**Elapsed time:** around 5 minutes.

Here D: is the Drive letter for SATADOM which has the installed WES 7 image, Aries.wim is the file name for the file that will be created (any name with file extension as .wim can be used). The last argument is numeric 1 to provide permissions to ImageX tool. The Aries.wim file should be created in current directory.

5. The image can now be copied to any other SATADOM disk with 32GB capacity say SATADOM 1.

   Before proceeding further make SATADOM1 Bootable by following the steps mentioned in Appendix A.

   To apply wim image to SATADOM refer Appendix I.

6.6 Using the Final image:

Power on the Aries SBC with SATADOM1 if the above steps are followed, otherwise with SATADOM. This will boot to the desktop in audit mode. (Time may be 1 hour or more)

1. The desktop can now be customized.
2. When the system restarts the below window on the desktop may appear. Cancel it by clicking on cancel button.

![System Preparation Tool 3.14](image)

*Figure 25: System Preparation tool for final image*
3. If the below image appears because sysprep is facing some problem because the USB drive is slow. Click **OK** and continue with the next step.

![System Preparation Tool 3.14](image)

Figure 26: Error while using Final image

4. Here you can install and customize whatever you need. For installing Display and Top Cliff Drivers for Aries, follow the steps mentioned below.

### 6.7 Installing Drivers and Software for Aries

Copy the driver folder provided with this document to a USB drive (Say **USB drive 4**), and connect the USB drive to the Aries SBC.

1. **Installing HyperTerminal:** Copy the files from `hyperterminal` folder to `c:\windows\system32`.
2. Copy the Programs to Demo Final Image:
   
   Copy the **AriesTestAppsv0.1** Folder to C:\ Directory.
3. **Installing Display Driver:**
   Run the `Driver\Graphics\Intel_EMGD.WIN7_PC_Version_36_15_0_1091Setup.exe`

4. **Installing USB 3.0 Driver:**
   Run `Driver\Intel(R)_USB_3.0_eXtensible_Host_Controller_Driver_3.0.5.69\Setup.exe`

5. **Installing Network Adapter driver:**
   Run the `Driver\PROWin32\APPS\SETUP\SETUPBD\Win32\SetupBD.exe` and restart the system on successful installation.

6. **Installing Windows Embedded IO driver:**
   Run the `Driver\Intel Atom Processor E3800 Embedded IO Drivers for Windows 7 (32-bit & 64-bit) - MR1\Intel Processor Win7 IO Drivers 32Bit.msi`

7. **Installing Diamond System Universal Driver 7.0.0:**
   Run the `Driver\Installer\dscud.exe`

Double click the “dscud.exe” file and follow the instructions. This program will detect whether the driver has already been installed. In case the driver is installed already, the board list screen will appear. For the uninstalled case, the following screen will appear.
Click on “Next” to proceed to the license agreement screen.

![Universal Driver 7.0.0 installation wizard](image)

**Figure 27: Universal Driver 7.0.0 installation wizard**

Read and Click on “Accept” on the End User License Agreement screen to proceed with the installation process.

![End User License Agreement](image)

**Figure 28: End User License Agreement**
• Click on “YES” when the pop up shown below is displayed to proceed with the installation.

![Figure 29: Install Universal Driver 7.0.0](image)

• During the installation of Diamond System's Universal Driver 7.0.0 driver, the pop up displayed on the screen below is shown.

![Figure 30: Installing Universal Driver 7.0.0 software](image)
During the installation of Universal Driver 7.0, the screen appears as shown for the driver signature.

Choose “Install this driver software anyway” option.

Figure 31: Windows Security

Add ISA Board

- Click the “Add ISA board” to add a new ISA board. The screen shown below will appear.
- Choose the board name, base address, IRQ from the combo boxes and click on “Install” to add the board.

Figure 32: Add ISA Board
• Clicking on “Install” will lead to the screen shown in Figure 33.

![Figure 33: Adding Aries SBC](image)

• On successful addition of the ISA board, the screen will appear as shown in Figure 34.

![Figure 34: Universal Driver 7.0.0 Device Manager](image)
6.8 Booting to Windows Welcome Mode

1. Open the command prompt with administrative privilege and run the following command:

   `C:\Windows\System32\Sysprep\sysprep.exe /oobe /generalize /shutdown`

   This SATADOM drive contains the final OS. Whenever this SATADOM drive is booted, it will boot to the Windows Welcome screen. To continue booting to Windows Welcome, follow the below steps.

   *Note: Take dump of the Windows Embedded Standard 7 by following the steps mentioned in section Step 5: Extracting WIM File. This will be the image to be applied to the Aries SBC.*

2. Restart the SBC with the SATADOM connected. It will reach the Windows Welcome screen and ask for First time boot inputs.

3. Now start using Windows Embedded Standard 7 on the Aries SBC.
7. APPENDIXES

Appendix A: Make USB/SATADOM Drive Bootable

i. Open a command prompt with administrator privilege.
ii. Run the following commands:
   - C:\Windows\system32> diskpart
     Microsoft DiskPart version 6.1.7601
     Copyright (C) 1999-2008 Microsoft Corporation.
     On computer: BIOS-8388

   - DISKPART> list disk
     Disk ### Status    Size     Free    Dyn    Gpt
     --------    --------    --------    ----    ---
     Disk 0    Online    232 GB    1024 KB    *
     Disk 1    Online    3861 MB    0 B

     Note: here disk 1 is the USBdrive2 that needs to be made bootable, please take care following step will remove all the data from the disk so select the correct Disk.

   - DISKPART> select disk 1
     Disk 1 is now the selected disk.

   - DISKPART> clean
     DiskPart succeeded in cleaning the disk.

   - DISKPART> create partition primary
     DiskPart succeeded in creating the specified partition.

   - DISKPART> select partition 1
   - DISKPART> active

   - DISKPART> format fs=ntfs quick
   - DISKPART> assign
   - DISKPART> exit

The USB/SATADOM drive is now bootable.
Appendix B: Install Windows Embedded Standard 7 Toolkit on a Development Computer

1. To run the Setup.exe command, do one of the following:
   - If you have the Standard 7 Toolkit DVD in the DVD drive, at the command prompt, type the following:
   - `<DVD DRIVE :>\Windows Embedded Studio\setup.exe`.
   - If you downloaded the `setup.exe` command, run it from the location where you saved it.

2. Follow the instructions in the installation wizard.

3. On the **Setup Type** page, do one of the following:
   - To install the tools and distribution share to the default location, select **Complete**. The default location for 32-bit is `[System Drive]\Program Files\Windows Embedded Standard 7` and for 64-bit is `[System Drive]\Program Files(x86)\Windows Embedded Standard 7`.
   - To install the tools and distribution share to a different location, select **Custom**.

4. Follow the instructions in the installation wizard to complete the installation for Standard 7 Toolkit.

Appendix C: Test HTTP Server

1. Make a copy of html file say index.html to “C:\inetpub\wwwroot” folder.
2. And add this as the default web page to load by editing the `applicationHost.config` file present in `%WinDir%\system32\inetsrv\config`. Open the `applicationHost.config` file and search for “iisstart.html” and replace it with “index.html”. Save the file and try to access the `index.html` file from a different computer as:
   - Open Internet Explorer in the development system also present in the same domain as the Aries board.
   - Type [http://192.168.0.1/index.html](http://192.168.0.1/index.html) and give Enter.

**Note:** 192.168.0.1 is the IP address of Aries board, this address can be found by using `ipconfig` command in command prompt.

The index.html page placed in “C:\inetpub\wwwroot” will be displayed on the development system’s Internet Explorer.
Appendix D: Test FTP Server

1. Click on Start and then Run.

2. Type the following command in the Open: text box, and then hit the Enter key or click on the OK button.
   
   `Iinetrmgr`

   IIS Manager should display right away. Below shown image is of IIS manager only.

   ![Figure 35: IIS Manager](image1)

   **Figure 35: IIS Manager**

3. Go to the left panel i.e. “Connections” panel and Right Click on the computer name showing in the list and select Add FTP Site... as shown in the below image.

   ![Figure 36: Add FTP Site](image2)

   **Figure 36: Add FTP Site**
4. After Selecting **Add FTP Site** you will get below shown image.

![Add FTP Site](image)

**Figure 37: Enter Site Information**

5. Here Type the following inputs and **Click** next.
   - **FTP site name:** Test
   - **Physical path:** C:\inetpub\ftproot

6. After clicking next you will get below shown image. Just Select **“No SSL”** and Click **next**.

![Binding and SSL Settings](image)

**Figure 38: Binding and SSL Settings**
7. The next screen will be the Authentication and Authorization Information Window as shown below.

![Authentication and Authorization Information Window](image)

**Figure 39: Authentication and Authorization Information**

Configure the following settings:

- Here Select the *Anonymous* and *Basic* check boxes.
- Set *Allow access to* “*Anonymous Users*”.
- Set Permissions to *Read* and *Write*.

The updated Window will appear as:

![Updated Window](image)

**Figure 40: Select Allow Access to Anonymous Users**
Click **Finish** to complete the FTP site adding process.

8. After adding FTP, permissions need to be set. Follow the below steps:
   Go to FTP Site that you added in IIS Manager. Right Click and select **Edit Permissions**.

   ![Edit Permissions](image1.png)

   **Figure 41: Edit Permissions**

9. Go to **Sharing** as below in shown Window.

   ![Select Advanced Sharing](image2.png)

   **Figure 42: Select Advanced Sharing**
10. Select **Advanced Sharing**. And make sharing on and give all the permissions to **Everyone** and **Users**.

11. Similarly Go to security in the same Window and give all permissions to the **current user**.

12. Open **C:\inetpub** and open Properties of folder **“ftproot”** and select **“Sharing”** tab. Select the **“Share”** button and add Administrator, and Everyone with **“Read/Write”** permission.

13. In the **“Security”** tab, ensure that everyone and Administrator has Read and execute permission.

14. **Turn Off the Firewall**: Open Control Panel->System and Security->Windows Firewall. In the Left Tab, select **“Turn Windows Firewall on or off”**, the below shown Window will appear:

![Figure 43: Turn off Windows Firewall](image)

Ensure that **“Turn off Windows Firewall (not recommended)”** is selected under sections **Home or work (private) network location settings** and **Public network location settings**.

15. **Restart** the system.

16. Go to **C:\inetpub\ftproot** Directory and place some Files or folder such as the test application for Aries board which has to be transferred.

17. Open Internet Explorer in the development system that is in the same network domain and try browsing to the path by providing **ftp://192.168.0.1** in the address bar and press Enter to browse.

*Note: 192.168.0.1 is the IP address of Aries SBC.*
18. All the files placed in the C:\inetpub\ftproot folder of the Aries board will be available in the Internet Explorer for user to access.

19. In the Internet Explorer Go to View then click on “Open FTP site in Windows Explorer”.

20. There is proper access to FTP Folders. The files can be accessed and copied from this location to local system.

21.

**Appendix E: Test OS Product Key License**

1. Open command prompt with Administrative privilege.
2. Change current working directory to c:\windows\system32 using CD command.
3. Give the below mentioned command:
   ```
   Cscript.exe slmgr.vbs –dli
   ```

**Appendix F: Start Hyperterminal**

Go to C:\windows\System32\hyperterminal

Double click on hyperterm

Hyperterminal should start.

**Appendix G: Create WinPE Bootable USB Drive**

Create a bootable thumb drive by following Steps in Appendix A. Next, Open a command prompt with administrator privilege in the Windows development System and use the following commands:

```xcopy C:\winpe_x86 .* /e F:\```

where winpe_x86 is the WinPE image to be copied to the thumb drive (F:).

This will create a bootable WinPE thumb drive. This can be used to take image dump from the Aries board without the need to connect any external hard disk.
Appendix H: Format the SATADOM

1. Connect a CD drive with windows 7 CD to the Aries SBC and select the CD Drive in the boot priority.

2. When the following screen appears, select the SATADOM of 32GB capacity and click on the “Drive options” and select “Delete”.

3. Power off the board.

4. Since the SATADOM interface to the ARIES SBC is same as the SATA interface (hard disk which contains the OS to boot the board), connecting both at a time is not possible. So in order to boot the board and format the SATADOM, install the Windows 7 OS in the mSATA which should be connected to the mSATA slot and SATADOM to the SATA interface. Now the board can be booted to the windows 7 from mSATA and the SATADOM which will act as the external drive can be formatted.

5. Power on the Aries SBC and format the SATADOM as per Appendix A.
Appendix I: Apply WE7 Image

1. Copy the Aries.wim and imageX.exe from the DVD and keep them in some folder in development or target PC. Let us assume that the folder path is C:\Temp.

2. Connect the 32 GB SATA DOM to development/target PC and format the SATA DOM (refer Appendix H) and make the SATA DOM bootable (refer Appendix A).

4. Use ImageX tool to apply the image to the 32GB SATA DOM (Let us assume that the SATA DOM drive is d:\ drive). Run the command as mentioned below.

   c:\Temp> imagex /apply ARIES.wim 1 d:

5. It will take minimum 10 minutes to apply the image in SATA DOM.

6. When the applied image is completed, the medium is ready to boot the OS.

7. Restart the SBC with the SATADOM connected. It will reach the Windows Welcome screen and ask for First time boot inputs.